Que faire en cas de problème avec le module PrestaShop ?

Dernière mise à jour : 06/27/17 à 11:01:36

En cas de difficulté rencontrée dans l'usage du module PayPlug pour PrestaShop, un bon réflexe est de désinstaller et supprimer le module puis de le réinstaller. Nous vous invitons par ailleurs à consulter les recommandations ci-dessous.


Le module n'apparaît pas en bout de panier après l'installation
Le module ne s'installe pas ou ne fonctionne pas après l'installation
Vous recevez des emails de notification d'erreur 500 après un paiement

 

Le module n'apparaît pas en bout de panier après l'installation


Si le module n'apparaît pas en bout de panier malgré une installation réussie vous devez vérifier les points suivants :
 

-  un transporteur doit être configuré depuis le menu "Transporteur" de votre back-office PrestaShop,

- vos pays de livraison doivent être sélectionnés depuis le menu "Modules et Services", puis menu "Paiements" puis section "Restrictions des pays",

- le pays de livraison doit être sélectionné dans la colonne "Activé" depuis le menu "localisation" et le menu "pays",

- la zone de livraison doit être activée depuis le menu "localisation",

- le menu doit être attaché au Hook : depuis le menu "Modules & Services" puis "Positions" cherchez la section "displayPayment" et "displayPaymentReturn" (ne vous occupez pas de "displayPaymentEU"). Il faut que le module PayPlug soit présent dans ces 2 sections, 

- rendez-vous sur la page de configuration du module puis vérifiez que le curseur "Afficher le module à mes clients" est bien au vert,

- étudiez la possibilité d'un conflit de module. En effet, il se peut qu'un module tiers agisse directement sur la solution de paiement, soit de par son mode de fonctionnement, soit parce qu'il a été mal écrit.

 

Le module ne s'installe pas ou ne fonctionne pas après l'installation


En cas d'erreur durant le processus d'installation du module ou de dysfonctionnements constatés (par exemple des doubles commandes), vous devez vérifier les points suivants :

- l'extension php curl doit être installée et activée (version 7.21 minimum),

- la version PHP de votre serveur doit être la 5.3 au minimum,

- votre serveur doit disposer d’une version 1.0.1 ou supérieure d'OpenSSL,

- existe-t-il un javascript en bout de panier en conflit avec le module Payplug? Ceci peut être provoqué par un module tiers ou un thème de mauvaise qualité,

- avez vous personnalisé votre thème ? Si votre thème a été modifié, cela peut entraver le bon fonctionnement du module PayPlug,

- avez vous personnalisé vos options de livraison ? Si vous avez modifié certains champs relatifs à ces options (par exemple vous avez modifié les pays existants) cela peut entraver le bon fonctionnement du module PayPlug,

- tel qu'indiqué dans la section précédente, vérifiez l'hypothèse d'un conflit de module.

En cas de difficultés persistantes, pensez à faire l'essai d'un panier d'achat sur votre site avec le mode sans échec de votre navigateur.


 

Vous recevez des emails de notification d'erreur 500 après un paiement

 

Si vous recevez des emails de notre part vous notifiant d'erreurs 500 suite à un paiement, nous vous invitons à vérifier les points suivants :

- les permissions sur les fichiers et le dossier où est situé le module PayPlug. Il faut notamment que vos dossiers aient les permissions 0755 et vos fichiers 0644. Les permissions ne doivent être ni trop ouvertes, ni trop restreintes,

- la configuration de votre fichier .htaccess, notamment les erreurs de paramètres des URL réécrites ou l'activation des URL simplifiées,

- les logs d'erreurs de votre serveur ou de votre site Internet,

- la configuration de votre serveur, notamment les temps de réponse dépassés,

- tous les changements que vous auriez pu opérer récemment.


 

Vous ne trouvez pas l'information que vous recherchez ? Effectuez une nouvelle recherche ou Contactez-nous.

803445684a0b5673a65cd2c2bc20d053@payplug.desk-mail.com
http://assets1.desk.com/
Chargement
il y a quelques secondes
il y a une minute
il y a quelques minutes
il y a une heure
il y a quelques heures
il y a un jour
il y a quelques jours
à propos de
false
Caractères non valides trouvés
/customer/fr/portal/articles/autocomplete
Testez la solution gratuitement dès aujourd’hui