If you are using a plugin for CMSs as PrestaShop or WooCommerce or if your developpments are base on the first version of the API, almost all the existing servers'configurations will work with your installation.
If you are using the second version of the PayPlug API, this is necessary for your server to have a minimum 5.3 PHP version and a 1.0.1 OpenSSL version.
Our new API version is based on a REST achitecture and needs to be connected to our servers using the TLS 1.1 and TLS 1.2 protocole. These protocole versions are supported by from the OpenSSL 1.0.1 version only.
This protocole use is imposed by the PCI DSS and among this the new 3.2 version.
If your web host still proposes older versions, we recommend you to contact them in order to ask for the component's update.
From 30/06/2016, within the PCI DSS all payment solutions won't be able to use TLS 1.0.